Unsupported major.minor version 51.0 错误解决方案

栏目:Eclipse大师 作者:admin 日期:2015-04-08 评论:1 点击: 39,519 次

jdk1.6工程中使用外部jar包中类出现:Unsupported major.minor version 51.0
原因分析:
出现上述错误是因为:外部jar包使用jdk1.7(jdk7)编译,而使用此jar包的工程jdk版本为jdk1.6(jdk6),算是版本不支持。 解决方法见下面的步骤:

第一步:在eclipse新增jdk1.7。如下图所示:

第二步:修改eclipse的编译环境jdk为1.7。具体步骤为:右击项目,选择属性,找到 java build path窗口,选择libraries标签,修改 JRE System libraries 为 1.7。如下图所示:
 

第三步:修改项目启动jdk为1.7。如下图所示:

知识扩充:
major.minor version,它相当于一个软件的主次版本号,只是在这里是标识的一个Java Class的主版本号和次版本号。
最后说明一下,遇到eclipse的问题,请加入群:278721352,在这里任何人提出的任何问题都有热心的群成员为你解答。
入群方式为:Java学习群[1]

网站公告
欢迎加入金燕知识社群,更多介绍请查阅:知识社群

Unsupported major.minor version 51.0 错误解决方案:目前有1 条留言

  1. 沙发
    test:

    :smile: 感谢楼主。问题解决了~ 非常感谢

    2017-05-04 上午9:41 [回复]

发表评论


------====== 本站公告 ======------
金丝燕网,即将迎来四周年!